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1 Introduction
Welcome to Release 1.2 of the Teradici PCoIP® Software Clients.

Teradici PCoIP® Software Clients are applications for Windows and Mac computers that allow
users to establish a PCoIP session with a remote workstation containing a Teradici PCoIP®
RemoteWorkstation Card. This release supports the following Teradici PCoIP Clients:

l Teradici PCoIP® Software Client for Windows
l Teradici PCoIP® Software Client for Mac

This guide explains how to install, configure, and use these software clients. It includes
details about the system requirements for client and host platforms and where you can find
the Teradici PCoIP Client log files.

1.1 Audience

This guide is intended for administrators who are responsible for setting up Teradici PCoIP®
Software Clients.

1.2 Additional Documentation

For a summary of feature additions, important bug fixes, and known issues for the Teradici
PCoIP® Software Clients, please refer to "Teradici PCoIP® Software Clients Release Notes"
(TER1301002).

For instructions on how to install and configure the PCoIP Host Software that is required on
the remote workstation, please refer to "PCoIP® Host Software for Windows User Guide"
(TER1008001).
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2 System Requirements
Teradici PCoIP® Software Clients are supported on the client and host platforms described
below.

2.1 Client Operating System

Teradici PCoIP Clients can be installed on laptops and desktop computers running the
following operating systems:

l Windows 8.1 (64 bit)
l Windows 7 (64 bit)
l Windows 7 (32 bit)
l Windows XP (32 bit)
l Mac OS X Mavericks (10.9)
l Mac OS X Mountain Lion (10.8)
l Mac OS X Lion (10.7)

Note: Teradici PCoIP® Software Clients do not operate with Windows Embedded Standard 7
orWindows Embedded Standard 8 systems.

2.2 Remote Workstation Platform

To be compatible with Teradici PCoIP® Software Clients, remote workstations must have the
following hardware, firmware, and software versions installed:

System Requirements Supported Versions

Teradici PCoIP® Remote Workstation Card l TERA22x0
l TERA1202

Teradici PCoIP Firmware 4.2.0 or later

Remote Workstation Operating System l Windows 7 (64 bit)
l Windows XP (64 bit)
Note: Connecting to Linux workstations using
Teradici PCoIP Clients is not supported in this
release.

Teradici PCoIP Host Software l PCoIP Host Software for Windows: 4.0.10 or
4.2.2 (or later)
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2.3 Remote Workstation Configuration Requirements

Before using a Teradici PCoIP Client to connect to a remote workstation, ensure that the
workstation is configured as outlined below.

2.3.1 Disable Temporal Dithering
If the graphics card (GPU) on the remote workstation supports temporal dithering, this
featuremust be disabled before establishing a PCoIP session. Otherwise, blurriness, heavy
packet loss, and high CPU usage will occur on the PC running the client during a PCoIP
session.

TheWindows Nvidia driver does not enable dithering by default, but most ATI drivers do. For
more information, please see Knowledge Base support topic 15134-207 on the Teradici
Support Center.
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3 Installing/Uninstalling Teradici PCoIP Software Clients

3.1 Prerequisites

Before installing a Teradici PCoIP Client:

1. Log in as administrator to the local machine or virtual desktop on which you will install
the program. The installation requires administrator privileges.

2. For best results, close all open applications before beginning the installation.

3.2 Teradici PCoIP® Software Client for Windows

3.2.1 Installing from the Windows Installation Wizard
1. Copy the Teradici PCoIP Client installer executable (PCoIP_Client_installer.exe) to your

local PC or virtual desktop.
2. Double-click the file to begin installation.
3. Click Next at the welcome screen to launch the installation wizard.

4. Accept the license agreement by clicking I Agree.
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5. Use the Browse button to select the folder in which to install the Teradici PCoIP Client
or accept the default, and then click Install.

6. If you do not have the latest Microsoft Visual C++ Redistributable package installed on
your machine, the following wizard appears to install the necessary runtime libraries.
Click Next.
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7. Enable I have read and accept the license terms, and then click Install.

8. Click Finish to exit theMicrosoft setup wizard.
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9. If desired, enable Create Desktop Shortcut, and then click Finish to exit the setup
wizard.

10. If you have created a desktop shortcut, the following icon will appear on your desktop:
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3.2.2 Installing from the Windows Command Line
You can also perform a silent installation of the Teradici PCoIP Client by typing the following
at the command-line prompt:

<location>\PCoIP_Client_installer.exe /S

where <location> is the full path to the folder containing the Teradici PCoIP Client installer.

Note: All default options are used for the silent installation. For example, a desktop shortcut
will not be created.

3.2.3 Uninstalling the Teradici PCoIP® Software Client for Windows
To run the uninstall script, select Start > All Programs > Teradici > PCoIP Client Uninstall on
the client Windows machine.

3.3 Teradici PCoIP® Software Client for Mac

3.3.1 Installing the Teradici PCoIP® Software Client for Mac
1. Copy the Teradici PCoIP Client disk image file (PCoIPClient.dmg) to your Mac desktop.
2. Double-click the file to mount the volume.
3. Accept the license agreement by clicking the Agree button.

4. In the PCoIPClient volumewindow, drag the PCoIPClient icon into the Applications
folder icon to install the program.
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5. If desired, you can also create an alias from this window:
a. Double-click on the Applications folder icon to open the folder.
b. Right-click on the PCoIPClient application in the list of applications, and then select

Make Alias from the popup menu.
c. Drag the alias to your desktop or Dock.

6. To eject the volumewhen you are finished, drag it to the trash.

3.3.2 Uninstalling the Teradici PCoIP® Software Client for Mac
Simply navigate to the Applications folder and drag the PCoIPClient program to the trash.
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4 Using Teradici PCoIP Software Clients

4.1 Connecting to a Teradici PCoIP® Remote Workstation Card

You can use a Teradici PCoIP Client to connect to a workstation either from the Teradici
PCoIP Client GUI or from a command line.

Note: When a session is first connected, it may take a few seconds before you can take
control of the keyboard and mouse. This is normal behavior.

4.1.1 Connecting Using the Teradici PCoIP Client GUI
1. Double-click the PCoIP Client desktop icon, alias, or program file (pcoip_client.exe for

Windows or PCoIPClient for Mac) to launch the application.

2. In theWorkstation Address text box, enter the fully qualified host name or IP address
of the Teradici PCoIP® RemoteWorkstation Card installed in the remote workstation.

3. Optional: In the Connection Name text box, enter a name for your connection. This
field accepts any Unicode character.
Note: This namewill be saved so that the next time you want to connect to this host,
you only need to click the saved connection name.
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4. Click the CONNECT button.

Saved Connections

If you have entered a connection name for a host, the Teradici PCoIP Client automatically
saves the connection details.

1. To reconnect, click the button for the saved connection. The button label displays the
connection name you assigned when you configured the connection, as shown in the
example below.
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2. To see the IP address, hover your mouse over the saved connection.
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3. To rename or delete a saved connection, click the configure button on the right, and
then select the desired option from the popup menu.

4. If you have saved multiple connections, simply click on the desired one to reconnect. If
you havemore than four saved connections, the additional saved connection buttons
will appear in an extended area of the page. Use the forward and back arrows to
navigate between areas.
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New Connections

To connect to a different host:

1. Click theNEW CONNECTION button.
2. Enter the workstation address and an optional connection name.
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3. Click the CONNECT button to connect, or the BACK button to return to the previous
menu without connecting or saving the connection.

4.1.2 Connecting Using the Command Line
To connect to a Teradici PCoIP® RemoteWorkstation Card by launching the Teradici PCoIP
Client from theWindows or Mac OS X command line:

1. Change to the directory where the Teradici PCoIP Client is installed. The default
locations are listed below:
l Windows: C:\Program Files (x86)\Teradici\PCoIP Client\bin
l Mac OS X: /Applications/PCoIPClient.app/Contents/MacOS

2. Type the following command at the prompt:
l Windows: pcoip_client -h <fully qualified host name or IP address of host card>
l Mac OS X: ./pcoip_client -h <fully qualified host name or IP address of host

card>

To see a list of all pcoip_client command parameters, type the following at the prompt:

l Windows: pcoip_client --help
l Mac OS X: ./pcoip_client --help
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4.2 Changing the Teradici PCoIP Client Window Mode

The Teradici PCoIP Clientwindow can be displayed in full-screen or windowed mode. Full-
screen is the recommended mode to use for best results.

From either client, use the View > Show/Exit Fullscreenmenu to change the screen mode.

You can also toggle between windowed and full-screen modes using the following key
sequence:

l Windows: Ctrl+Alt+Enter
l Mac OS X: option+command+return

Note: Maximizing the window does not put the Teradici PCoIP Clientwindow into full-screen
mode.

4.2.1 Displaying the Utility Menu Bar
In full-screen mode, Teradici PCoIP Clientmenus are located in a drop-down utility menu
bar. You can display this menu bar by moving themouse cursor to the top of the screen.

4.3 Sending Ctrl+Alt+Del

To send the Ctrl+Alt+Del keyboard command to a remote workstation from either client,
select the Connection > Send CTRL-ALT-DELmenu option.
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4.4 Checking the Performance Indicator

During a PCoIP session, a square performance indicator appears in the systems tray of a
Windows client computer or in themenu bar of a Mac client computer. This icon changes
color depending on the quality of the connection and the data throughput between the
client and the host:

l Green: Session optimal
l Orange: Session laggy
l Red: Session lost

4.5 Checking the Software Release

The Teradici PCoIP Client GUI contains an About button in the lower left area of the window.
Click this button and then select About from the popup menu to display the Teradici PCoIP
Client software release version.

Note: The build number shown in the examples belowmay differ from the build number in
your release.
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For either client, you can also select the Teradici PCoIP Client > About Teradici PCoIP Client
menu to display the software release version from within a PCoIP session.

4.6 Disconnecting a Session

To disconnect a PCoIP session from either client but still leave the Teradici PCoIP Client
application running, select the Connection > Disconnectmenu.
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4.7 Quitting the Teradici PCoIP Client Application

Note: If you have not disconnected your PCoIP session, quitting the Teradici PCoIP Client
application also disconnects the session.

To quit the application:

l For Windows, select the Teradici PCoIP Client > Quit Teradici PCoIP Clientmenu.
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l For Mac, select theMac OS X Teradici PCoIP Client > Quit Teradici PCoIP Clientmenu
(or simply press command+Q).
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5 Troubleshooting
If you experience a problem and require customer support, please log in to the Teradici
Support Center and submit a trouble ticket. To help engineers analyze the problem, attach
as much relevant information as you can, such as screen shots and Teradici PCoIP Client log
files.

5.1 Teradici PCoIP Client Log Files

The Teradici PCoIP Client logs are text (.txt) files that contain system and session information
about your connection, and are therefore useful for troubleshooting problems. A new log file
is created each time you use a Teradici PCoIP Client to initiate a PCoIP session.

The figure below shows some sample entries in a Teradici PCoIP Client log file.

5.1.1 Locating Teradici PCoIP Client for Windows Log Files
For computers running Windows, you can access Teradici PCoIP Client log files as follows:

1. Open aWindows Explorer window.
2. Use the address bar at the top of the Explorer window to navigate to the logs:

l For Windows 7 and Windows 8 (64 bit), navigate to the following folder:
C:\Users\<user_name>\AppData\Local\teradici\PCoIPClient\logs

l For Windows XP, type the following path in the address bar:
C:\Documents and Settings\<user_name>\Local Settings\application
data\Teradici\PCoIPClient\logs

3. Copy and paste the file to another location, or double-click it to open the file and
display its contents.
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5.1.2 Locating Teradici PCoIP Client for Mac Log Files
On aMac computer, Teradici PCoIP Client log files are located within the user's Home Library
folder, which is hidden by default. The recommended way to access Home Library files is to
use theMac OS X Console.

1. To open the Console, go to the Applications > Utilities folder, and then double-click
Console.

2. In the FILES section of the Log List pane on the left, navigate to the following folder:
~/Library/Logs/Teradici/PCoIPClient

3. Select the desired log file to view its contents in themain pane.
4. To copy the contents:

a. Click anywhere in the log contents, and then select Edit > Select All.
b. Select Edit > Copy.
c. Paste the contents into an email or text file.

You can also display log files in a Mac OS X terminal window.

1. To open a terminal window, go to the Applications > Utilities folder, and then double-
click Terminal.

2. Navigate to the Teradici PCoIP Client log folder by typing the following command at the
command line prompt:
cd ~/Library/Logs/Teradici/PCoIPClient

3. Type ls to display the list of log files.
4. To view the contents of a log file, use any Mac OS X command-line editor to open it.
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Glossary of Definitions
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DisplayPort
A type of digital video interface used in
2nd generation Teradici PCoIP Remote
Workstation Cards (miniDP), 2nd gen-
eration Teradici PCoIP Zero Clients, and
also in some graphics cards.

DVI
Digital Visual Interface. A type of digital
video interface used in 1st generation
Teradici PCoIP Remote Workstation
Cards and Teradici PCoIP Zero Clients,
some 2nd generation Teradici PCoIP
Workstation Cards and Teradici PCoIP
Zero Clients, and also in some graphics
cards.

GPU
Graphics Processing Unit. The graphics
card on a PC or workstation.

log files
Text files that contain system and session
information about each PCoIP session.
Teradici PCoIP Software Client log files
begin with "pcoip_client_", followed by
the date the log was created, a unique
identifier, and a ".txt" extension.

PCoIP Host Software for Linux
A software package on a host Linux PC or
workstation that allows administrators to
manage some Teradici PCoIP Remote
Workstation Card features used by the
Teradici PCoIP Software Clients.

PCoIP Host Software for Windows
A software package on a hostWindows
PC or workstation that allows admin-
istrators to manage some Teradici PCoIP

Remote Workstation Card features used
by the Teradici PCoIP Software Clients.

TERA1202
First-generation Teradici processor sup-
porting Teradici PCoIP Remote Work-
station Card functionality. TERA1202
cards support two displays at a resolution
of 1920x1200.

TERA2220
Second-generation Teradici processor
supporting Teradici PCoIP Remote Work-
station Card functionality. TERA2220
cards support two displays at a resolution
of 1920x1200 or one display at a res-
olution of 2560x1600.

TERA2240
Second-generation Teradici processor
supporting Teradici PCoIP Remote Work-
station Card functionality. TERA2240
cards support four displays at a res-
olution of 1920x1200 or two displays at a
resolution of 2560x1600.

Teradici PCoIP host
The host or server side of a PCoIP sys-
tem. In this release, Teradici PCoIP Soft-
ware Clients support connections to
remote Windows and Linux workstation
hosts containing Teradici PCoIP Remote
Workstation Cards.

Teradici PCoIP Software Clients
Applications for Windows and Mac com-
puters that allow users to establish PCoIP
sessions with Teradici PCoIP Remote
Workstation Cards.
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